Follow

Getting started with Rossignol and PIQ

Rossignol and PIQ is compatible with iOS 8.0+ (iPhone 4S minimum) and Android OS 4.3+. Please, make sure that your device supports BLE 4.0.

To download and install the Rossignol and PIQ app, search Rossignol and PIQ on the AppStore (iOS version) or Rossignol and PIQ on Google Play (Android version).

  • Launch the application
  • Click on "Sign up"
  • Select your contry
  • Enter your Phone number in international format. Please, make sure that you operator provides receiving SMS
  • Receive a verification code via text message, type it and click on "Continue"
  • Fill in all the profile fields and click on "Save"

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request

Comments